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Kapitel 1

Verarbeitung von DICOM Daten mit
ImageJ

In den letzten Jahren wurden die klassischen, analogen bildgebenden Verfahren in der Radiologie im-
mer mehr durch digitale Verfahren ersetzt. Computer haben einen wichtigen Platz in der medizinischen
Bildverarbeitung̈ubernommen.

1.1 Der DICOM Standard

DICOM - Digital Imaging and Communication in Medicine
DICOM ist das am weitesten verbreitete Format zur Speicherung,Übertragung und Verarbeitung digitaler medizi-
nischer Bilddaten. Der DICOM Standard definiert sowohl ein Format das nicht nur die Pixeldaten der eigentlichen
Aufnahme, als auch Metainformationen zum Patienten, dem Gerät, sowie den Aufnahmeparametern enthält. Die
eigentlichen Bilddaten k̈onnen hierbei unkomprimiert oder mittels Run-Length-Encoding oder JPEG1 komprimiert
vorliegen.
Die Metainformationen des Bildes werden im DICOM-Header kodiert. Der Header besteht aus Schlüssel-Wert-
Paaren, den Tags. Die Anzahl und der Typ der vorhandenen Tagsist je nach Modaliẗat verschieden. Zusätzlich zu
dem im Standard definierten Tags hat jeder Hersteller die Möglichkeit weitere Werte in privaten Tags zu kodieren.
Bei der Arbeit mit medizinischen Bildern sind diese Metainformationen beinahe genau so wichtig wie die eigent-
lichen Bilddaten. Aus diesen Grund müssen Softwarelösungen, die mit DICOM Bildern arbeiten, in der Lage sein
auch diese Informationen aus den Bildern zu Nutzen.

1.2 DICOM in ImageJ

ImageJ selbst unterstützt bereits das Laden und Verarbeiten von DICOM Dateien sowie den Zugriff auf den DI-
COM Header. Jedoch sind die integrierten Funktionen sehr limitiert, da nur unkomprimierte Bilder geöffnet werden
können. Auch das Speichern von Bildern im DICOM-Format ist nicht möglich. Da viele der bereits vorhandenen
DICOM Erweiterungen f̈ur ImageJ nur spezielle Teilprobleme abdeckten oder nicht weiter entwickelt werden,
starteten wir, die Entwicklung der TUDOR DICOM Tools, einerSammlung von ImageJ Plugins und Programm-
bibliotheken zur Verarbeitung von DICOM Bildern auf der Basis von ImageJ.

1.3 Die Tudor DICOM Tools

Wie ImageJ selbst sind auch die TUDOR DICOM Tools als Open Source kostenlos erḧaltlich. Die Tools erweitern
ImageJ nicht nur um Funktionen wie das Laden und Speichern von diversen DICOM Formaten, sie bieten auch
einen besseren Zugriff auf die im Header enthaltenen Metainformationen. Auch die im DICOM Standard enthal-
tenen Funktionen zum Versenden und Empfangen von Bildern via Netzwerk oder das Erstellen und Lesen von
DICOMDIR Strukturen, wie sie auf DICOM CDs zum Einsatz kommen, werden unterstützt.

1Joint Photographics Experts Group
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Installation Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

• Lesen/Schreiben von DICOM Dateien

• Zugriff auf DICOM CDs

• Empfang von DICOM Bildern mittels integrierter DICOM-STORE SCP

• Senden von DICOM Bildern mittels DICOM-SEND SCU

• Abrufen von Bildern aus PACS2 Systemen mittels DICOM-QUERY-RETRIEVE SCU

• Verarbeitung und Darstellung der Bild Metainformationenim DICOM-Header

• Anonymisierung von DICOM Bildern

• Darstellung von Bildern mittels integriertem DICOM Viewer

• Bildverarbeitung jeglicher Art durch die M̈oglichkeiten von ImageJ

Die meisten dieser Funktionen können direkt aus ImageJüber einen Eintrag im Plugin-Menü aufgerufen werden.
Auch ist es m̈oglich, sie direkt in ImageJ aufgezeichneten Makros zu verwenden und so eigene, automatisierte
Arbeitsabl̈aufe zu erstellen. Zusätzlich sind die meisten Funktionen und Einstellungenüber ein kleines Mana-
ger Panel, den DICOM Manager zu erreichen. Dieser kannüber das ImageJ Menü gestartet werden.Plugins →
TUDOR DICOM Tools → DICOM Manager

Abbildung 1.1: Manager Panel der DICOM Tools

1.4 Installation

Die TUDOR DICOM Plugins ben̈otigen mindestens Version 1.5 of the Java Runtime Environments (JRE3)
Zum Installatieren der Tudor DICOM Tools entpacken sie die .zip Datei der Plugins im Verzeichnis ihres installier-
ten ImageJ. Das .zip Archiv enthält alle ben̈otigten externen Bibliotheken im Verzeichnis plugins/TudorDICOM-
Libs, sowie die .jar Datei des Plugins plugins/TudorDICOMPlugin.jar.
Um auch komprimierte DICOM Dateien öffnen zu können wird zus̈atzlich die Java ImageIO Erweiterung
benötigt. Diese Erweiterung muss abhängig vom verwendeten Betriebssystem heruntergeladen werden.
https://jai-imageio.dev.java.net/binary-builds.html
Für Windows Betriebssysteme laden und installieren sie bitte die folgende Version:
http://download.java.net/media/jai-imageio/builds/release/1.1/jai\textunderscoreimageio-1\textunderscore1-lib-windows-i586-jre.exe
Weitere Informationen zur Installation der Java ImageIO Erweiterung finden sie unter:
http://download.java.net/media/jai-imageio/builds/release/1.1/INSTALL-jai\textunderscoreimageio.html\#Windows
Nach erfolgter Installation der Plugins und der Java ImageIO Erweiterung ist es notwendig ImageJ zu schließen
und neu zu starten.

1.5 Konfiguration

Um die Arbeit mit den Plugins zu vereinfachen ist es sinnvollvor der ersten Nutzung einige Dinge zu konfigurieren.
Den Einstellungs-Dialog finden sie im ImageJ Menü unterPlugins→ TUDOR DICOM Tools → Settings.

2Picture Archiving and Communication System
3Java Runtime Environment
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Konfiguration Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

• Mittels setzen eines Hakens können die einzelnen Funktionalitäten des DICOM Dateidialoges Ein- bzw.
Ausgeschaltet werden.

• In den Optionen zum̈offnen von DICOM Dateien vom Dateisystem, einer DICOM-CD oder einem lokalen
DICOMDIR (lokale Kopie einer DICOM-CD) k̈onnen nun die Startpfade gesetzt werden. Der Dialog startet
so sp̈ater immer direkt im geẅahlten Verzeichnis.

• Die DICOM Tools enthalten einen einfachen DICOM STORE (SCP) Knoten der es erm̈oglicht Daten direkt
per DICOM-SEND an ImageJ zu senden. Bei aktiviertem STORE muss f̈ur diesen ein Speicherverzeichnis,
sowie ein AE4 Titel und Netzwerkport angegeben werden.

• Die DICOM Tools k̈onnen direkt mittels DICOM QUERY auf ein konfiguriertes PACS2 zugreifen. Bei
aktiviertem DICOM QUERY muss für dieses die Netzwerkadresse sowie Port und AE4 Titel des PACS2

Systems angegeben werden.

Abbildung 1.2: Konfiguration der DICOM Tools 1/2

• Die DICOM Tools enthalten die M̈oglichkeit Bilder von ImageJ an andere DICOM Knoten zu senden. Die
empfangenden Systeme müssen hierzu mit ihrem AE4 Titel, dem sendenden AE4 Titel, Netzwerkadresse
sowie Port eingetragen werden.

• Der DICOM Dialog bietet an vielen Stellen eine Vorschau dergeẅahlten Bilder incl. Headerdaten. Die in
der Vorschau geẅunschten Felder des DICOM-Headers können in den Einstellungen einfach Zeilenweise
getrennt eintragen oder mittels eines Auswahldialoges hinzugef̈ugt werden.

4Application Entity
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Öffnen, Empfangen und Verwalten Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

Abbildung 1.3: Konfiguration der DICOM Tools 2/2

1.6 Öffnen, Empfangen und Verwalten

Als zentrale Plattform f̈ur das Laden, Senden, Empfangen und Verwalten von Dateien ist ein komfortabler Datei-
dialog integriert. Der DicomOpenDialog gliedert sich in Bereiche f̈ur den Zugriff auf die lokale Festplatte, DICOM
CDs oder den Zugriff auf erreichbare PACS2 Server via Netzwerk. Mittels des integrierten Image Selectors k̈onnen
problemlos ganze Verzeichnisse nach DICOM Dateien durchsucht und diese nach Werten im DICOM Header ge-
filtert werden. So k̈onnen z.B. Dateien einer bestimmten Modalität oder Aufnahmeart gefunden und selektiert
werden. Der DicomOpenDialog bietet eine Vorschaufunktion, die sowohl das Bild als auch frei konfigurierbare
Tags des Headers anzeigt. Dies bietet einen deutlichen Vorteil gegen̈uber den Dateimanagern des Betriebssystems,
die meist keine Vorschau von DICOM Bildern erlauben und so das Auffinden von bestimmten Bildern erschweren.
Beim Zugriff auf PACS2 Systeme, das integrierte DICOM-STORE oder DICOM CDs, gliedert sich die Ansicht
nach Patient, Studie, Serie, Bild – wie es auch in anderen PACS2 Konsolen oder DICOM Workstations gehandhabt
wird. BeimÖffnen, Senden und L̈oschen wird immer die tiefste selektierte Ebene verwendet.Um z.B. eine ganze
Serie zuöffnen, darf im Bereich Bild kein Eintrag selektiert sein.
Sie erreichen den DicomOpenDialogüber den DICOM Manager oder den Open DICOM Eintrag in ImageJ
File → Import → Open DICOM
Plugins→ TUDOR DICOM Tools → DICOM Manager
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Senden Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

Abbildung 1.4: Dateidialog der DICOM Tools – STORE Ansicht.

1.7 Senden

Die DICOM Tools bieten die M̈oglichkeit Bilder direkt aus ImageJ oder von dem lokalen Rechner an andere DI-
COM fähige Applikationen (PACS2) oder Ger̈ate (Drucker, Brenner) im eigenen Netzwerk zu senden. Das Senden
von Bildern kann̈uber einen Eintrag im ImageJ Menü Plugins→ Tudor DICOM → Send DICOM oder aus dem
DicomOpenDialogs erfolgen. Zum Senden muss eine der in den Einstellungen eingetragenen Empfängeradressen
ausgeẅahlt werden. Der hierzu erscheinende Dialog gibt Auskunftüber die Erreichbarkeit der Empfänger.

Abbildung 1.5: Senden von DICOM Dateien an andere Knoten.
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Speichern / Exportieren Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

1.8 Speichern / Exportieren

Mittels des Men̈u EintragesFile → Save As→ Save DICOM können Bilder aus ImageJ als DICOM Dateien ex-
portiert werden. Unterstützt werden hierbei 8 und 16bit Monochrome sowie 24bit RGB5 Bilder. Beim Exportieren
kann mittels eines Dialoges der Patientenname und ID neu gesetzt sowie Institutions und Herstellerdaten entfernt
werden. Falls das zu exportierende Bild schon vorher im DICOM Format vorlag, wird sein DICOM Header in das
exportierte Bildübernommen. Falls ein Bild eines anderen Formates nach DICOM exportiert wird, so wird ein
DICOM Header mit den grundlegenden, notwendigen Tags generiert.

Abbildung 1.6: Exportieren als DICOM

1.9 Arbeiten mit dem DICOM Header

1.9.1 DICOM Header Ansicht

Die DICOM Tools bieten zus̈atzlich erweiterte Funktionalitäten beim Zugriff auf den DICOM Header. Durch die
Integration einer vollsẗandigen Liste aller DICOM Tags kann der Header vollständig angezeigt werden, wobei
auch die privaten Felder der Hersteller zugänglich sind. Die enthaltene Volltextsuche sowie der Vergleich mehre-
rer DICOM Header erleichtern das Auffinden bestimmter Tags wie z.B. ger̈atespezifischer Parameter. Auch das
anonymisieren ganzer Ordner von Bildern lässt sich mittels eines integrierten Tools mit wenigen Klicks erledigen.
Beim Anonymisieren kann geẅahlt werden, ob nur die persönlichen Patientendaten ersetzt oder auch die Daten
der Institution und des Geräteherstellers gelöscht werden.

Den DICOM Header einer Datei erreichen sieüber verschiedene M̈oglichkeiten. Schon im DicomOpenDialog
kann durch eine Schaltfläche im Vorschaubereich der komplette DICOM Header einer Datei angezeigt werden. Um
den Header des aktuell in ImageJ geöffneten Bildes anzuzeigen erreichen sie selbigen Dialogüber den folgenden
Menüeintrag:Plugins→ TUDOR DICOM Tools → Show DICOM Header
Alternativ gibt es die M̈oglichkeit den Header im Hexadezimal Format anzuzeigen. Dies kann hilfreich sein um
Problemen aufgrund falscher Dateikodierung etc.. auf die Spur zu kommen, die bei der Interaktion verschiede-
ner Softwareprodukte auftreten können. Die Hexadezimalansicht des Headers erreichen Sieüber den folgenden
Menüeintrag:Plugins→ TUDOR DICOM Tools → Show DICOM Hex
Um die DICOM Header zweier, verschiedener Dateien miteinander zu vergleichen, k̈onnen diese in einer Diff-
Ansicht nebeneinander geöffnet werden. Auch in dieser Ansicht kann im Inhalt der Felder gesucht werden. Den
DICOM-Header-Vergleich erreichen sieüber die entsprechende Schaltfläche im DICOM Manager Panel.

5Red, Green, Blue Color Model
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Arbeiten mit dem DICOM Header Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

Abbildung 1.7: DICOM Header Ansicht

1.9.2 Anonymisierung

Bei der Arbeit mit medizinischen Daten tritt oft die Notwendigkeit einer Anonymisierung der Daten auf. Da auch
die meisten DICOM Bilder in ihren Headern Patienten und Institutionsdaten enthalten, wird auch hier desöfteren
eine Anonymisierung benötigt. Über den mittels des Manager Panels zu erreichenden DicomAnonymizer k̈onnen
sehr einfach einzelne Bilder oder ganze Verzeichnisse auf einmal anonymisiert werden.

Nach Auswahl der Bilder̈uber den DICOM Filechooser können Patientenname sowie ID neu vergeben werden. Die
meisten anderen patientenbezogenen Tags werden gelöscht oder mit leeren Werten̈uberschrieben. Patientenalter
und Geschlecht bleiben für statistische Zwecke erhalten. Zusätzlich wird das Tag “PatientIdentityRemoved” gesetzt
um die Anonymisierung zu kennzeichnen. Bei Bedarf können auch alle Tags die Informationen zur Institution
oder dem Ger̈atehersteller enthalten aus den Bildern entfernt werden. Mittels der “run” Schaltfl̈ache kann das
Anonymisieren gestartet werden.ACHTUNG! Die Original Bilder werden hierbei mit den anonymi sierten
Bildern überschrieben.

Abbildung 1.8: Anonymisierung von DICOM Dateien
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Arbeiten mit dem DICOM Header Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

ACHTUNG! Manche Bilder enhalten zusätzlich Patientendaten die direkt in die Pixeldaten des Bildes ge-
schrieben sind (z.B. Ultraschall). Diese Patientendaten werden beim anonymisieren nicht entfernt und somit
die Bilder auch nicht vollständig Anonymisiert.

1.9.3 DICOM Headerdaten Auswertung

Die TUDOR DICOM Tools enthalten ein Programm das es erlaubt auf einfache Art und Weise gezielt Header-
Informationen aus großen Bildmengen zu extrahieren. Zusätzlich lassen sich Filter definieren um Bilder anhand
bestimmter Header-Informationen auszugrenzen oder einzuschließen. Ein Im- und Export der Einstellungen er-
laubt eine einfache Weitergabe der Auswertungsparameter.
Die Auswertung erfolgt in 4 Schritten:

1. Auswahl der zu untersuchenden Bilder per DICOM File Chooser.

2. Laden der vorhandenen Tags aus einen passenden Bildes - Alternativ Anzeige aller bekannten DICOM Tags.

3. Auswahl der geẅunschten Ergebnis Tags via “Drag and Drop”.

4. Auswahl der Filter Tags via “Drag and Drop”.

5. Anpassung der Filter Tags via Editor oder Regexp.

6. Start der Auswertung mittels Schaltfläche “Headerdaten Sammeln”.

Abbildung 1.9: Headerdaten Auswertung: Auswahl der Tags und Filter

Nach erfolgter Auswertung werden die gesammelten Daten für alle Bilder in einer Tabelle angezeigt. Aus dieser
Tabelle k̈onnen die Ergebnisse gedruckt oder in eine CSV6 Datei exportiert werden. Diese kann Problemlos von
Excel oder anderen statistischen Programmen geöffnet werden.

6Comma-Separated Values
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Der Tudor DICOM Viewer Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

Abbildung 1.10: Headerdaten Auswertung: Ergebnisansicht

1.10 Der Tudor DICOM Viewer

Der in den Tools enthaltene TUDOR DICOM Viewer vereint alle Funktionen der DICOM Tools zu einer einfach
zu benutzenden Anwendung zur Anzeige von DICOM Dateien. DerViewer wird als eigenständige Applikation
gestartet, verwendet aber intern ImageJ zur Verarbeitung und Anzeige der Bilder. Je nach gewählter Ansicht las-
sen sich bis zu vier Bilder gleichzeitig betrachten. Auch Multi-Monitor Konfigurationen sind m̈oglich. Bildserien
können von diversen Quellen in eine Liste geladen werden und sind so jederzeit sofort mit Vorschau und einigen
Bildinformationen zugreifbar. Mittels der Maustasten undMausrad kann bequem im Bild gefenstert und durch die
Serie navigiert werden. Andere Funktionen wie Zoom, Verschieben, Messen, Invertieren etc.. sindüber die inte-
grierte Toolbar zu erreichen. Wichtige Informationen wie Name und Geburtsdatum des Patienten können im Bild
eingeblendet werden. Sollten die Funktionen im Viewer nicht ausreichen oder weitere Analysen des Bildes nötig
sein, so l̈asst sich jedes Bild direkt in ImageJöffnen und weiterverarbeiten.

Abbildung 1.11: Der TUDOR DICOM Viewer.
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Zusammenfassung Kapitel 1. Verarbeitung von DICOM Daten mit ImageJ

1.11 Zusammenfassung

ImageJ bietet zusammen mit den TUDOR DICOM Tools eine mächtige und kostenlose Lösung zur Visualisierung
und Verarbeitung von DICOM Dateien. Durch das integrierte Scripting lassen sich Arbeitsabläufe automatisieren.
Durch die m̈ogliche Nutzung von ImageJ und den DICOM Tools als Programmbibliothek lassen sich so eigene
DICOM fähige Applikationen entwickeln. Abteilungsintern werdendie DICOM Tools bereits in einer entwickel-
ten Praxissoftware sowie in diversen Programmen zur Qualitätskontrolle von Radiologiegeräten genutzt. Weitere
Informationen sowie den Download der Tools finden sie unter:http://santec.tudor.lu/project/optimage/dicom/start

Fragen und Kontakt
Johannes Hermen - Ingenieur de Recherche
CRP Henri Tudorhttp://www.santec.tudor.lu
2A, rue Kalchesbr̈uck
L-1852 Luxembourg

1.12 Aufgaben

1. Installation der TUDOR DICOM Tools.

2. Konfiguration der Tools: Einstellen der Pfade für Verzeichnis und CD Konfiguration des Stores, Nachbar-
rechner als Empfänger eintragen.

3. Öffnen von DICOM-Einzelbildern sowie Stacks vom lokalen Dateisystem.

4. Zugriff auf eine DICOM-CD.

5. Senden/Empfangen von Bildern aus dem Dicom-Dialog: Senden an den Nachbarrechner.

6. Öffnen/Löschen von Bildern aus dem lokalen DICOM-Store.

7. Bearbeiten (beschneiden/invertieren) eines Bildes in ImageJ und anschließendes exportieren als DICOM.

8. Ansicht eines DICOM Headers in Text und HEX.

9. Vergleich zweier DICOM Header: selbe Serie, unterschiedliche Serie.

10. Anonymisieren von DICOM Dateien: Header vergleichen, vorher/nachher.

11. Headerdaten Auswertung: Festlegen von Parametern und Filtern, Auswertung starten, exportieren undöffnen
in Excel.

12. Ausprobieren des DICOM Viewers.
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